Power Apps Exchange

Please login or click SIGN UP FOR FREE to create your PowerAppsUG account to join this user group.
 View Only
  • 1.  Getting your data

    Posted Dec 06, 2021 11:07 AM

    Hello All,
    I have been working on a canvas app that I thought was working well but have learned that when users go through the second new record creation it stalls out with a "getting your data" message.

    I have an initial user input screen where an employee's serial number is entered along with scanning a code for the process that they are being trained on.  If this combination is already in the SharePoint list that is the repository for this training information then it shows up in a galley, if not, the trainer will select enter new record which navigates them to a new screen and prepopulates the serial # and process information in a form whose DefaultMode is New.  Upon completion of the form there is s submit button which writes to the SP List and takes you back to the initial data screen where they can start over for the next process.  The issue is that the "second" time we get this "Getting your data" message.  I have been searching for a solution ,and thought I had it from another post on this site.  I added "Defaults('my data source')" to the Item attribute of the entry form.  This worked for the 1st and 2nd entry but upon the third, it overwrote the defaults that I had in the form to match previous entries.  This I do not understand and any insight would be appreciated.

    1st & 2nd consecutive usage (these are the defaults):

    3rd usage (defaults change):



    ------------------------------
    Kendall Casper
    ------------------------------


  • 2.  RE: Getting your data

    Top Contributor
    Posted Dec 06, 2021 11:13 PM
    In the OnSuccess property of the form, are you doing NewForm(Form1) or whatever your form is called if not Form1?

    ------------------------------
    Will Page
    Technical consultant
    Christchurch, NZ
    ------------------------------



  • 3.  RE: Getting your data

    Posted Dec 07, 2021 09:56 AM
    No,  I have not tried that.  The sequence in the app is as follows.
    After entering Clock# and scanning the process QR if there is not an existing training record, the user will select "New Record".  this navigates to the following screen:
    The information is passed between the screens and populated into the form shown at the top.  This form DefaultMode is set to New.  After selecting the "save" icon, validation occurs and if there are no issues navigates back to initial screen.  Where would I put the newform(Form1)? and would that be the initial form or the "new training" form?

    ------------------------------
    Kendall Casper
    Assistant General Manager
    ------------------------------



  • 4.  RE: Getting your data

    Posted Dec 08, 2021 10:50 AM
    I figured out what you meant, that seems to have worked.  Thank you so much for your suggestion and guidance.

    ------------------------------
    Kendall Casper
    Assistant General Manager
    ------------------------------